Mobile is shutting down randomly issue

102°
Deal Subedar
0
1162
12

Today suddenly my mobile switched off, at that time battery was 67%,

After so many attempts, it got on and battery showed 30%, later it switched off again and later when I was able to switch it on, it showed 43%

Mobile is shutting down randomly even though battery is 60% or 80% or 50%

Now
Once it shut down, it doesn’t restart
By using charger I am able to switch on my mobile

Any idea guys, what is the problem?

Should I go to local mobile shop or Authorized service center?(Mobile is 3 years old, Runs on Android Oreo)
Asus Zenfone 3 ZE520KL

Thanks

P.S.
I have searched over internet about the issue-
What I found that it may software issue or due to any app or may be hardware issue

I tried all troubleshooting for software issue except for hard reset, will do it after doing data backup.

Probably I may have to go for repair service-So I wanted to know where should I visit Authorized service center or Local Mobile repairing shop?

16 Comments  |  
12 Dimers
  • Sort By
101
6853
179

Most likely a dying battery esp. considering its 3 years old. Rarely it could be a battery calibration issue.
You should have mentioned the product name at the very least.

0
1162
12
LIMBO wrote:

Most likely a dying battery esp. considering its 3 years old. Rarely it could be a battery calibration issue.
You should have mentioned the product name at the very least.

Updated-
Asus Zenfone 3 ZE520KL

120
1027
19

Get it checked up at a local service centre. Could be something to do with the power IC, specially if you dropped the phone hard a few times.
Dont go to authorised service centres as they do not do chip level repairs.

173
1740
13

I think its a battery issue, most probably it is at end of life cycle.
There are some secret codes for asus to check hardware functionality.
I can’t remember exactly but google it and try on your own risk.
Check this page https://mobileresets.com/asus-secret...es
*#0228# is battery status code there mentioned but before trying anything back up data.

50
305
2

My Redmi note 7 pro was also restarting randomly & did not boot completely without plugging charger. The main sign of a obsoleted battery is battery level will drain quickly as you unplug charger cable. The battery percentage keep go up & down after restarts. Another sign is battery draws less current around 2.5 Watt from a charger. You can test it if you have USB power tester. There could be also with charging circuitry but chances are very slim, also your phone has been more than 3 years, so 99% chances battery is almost dead.
I will never recommend you to get a replacement battery from local a shop if that phone not much important for you. Local cheap chinese battery are not accurate in capacity & may not last more than 3 months. If you want to use your phone for long time, always replace  battery from authorized service center My RN7pro has 4000Mah battery, got replacement from MI centre at Rs1350.

1,935
5748
77

You did all recent firmware updates bro? I think it needs a battery upgrade, nothing else. Is it still booting up?

409
1605
17

90% it is battery problem
I had issue similar issue with redmi note I have changed the battery the issue got solved

92
1228
8

where u using a charger other than d one provided by company?

101
6853
179
Install Accubattery. It takes at least 15-20 charging sessions for somewhat accurate estimate of battery health.

With a USB Battery Tester its easier to gauge battery health in just 2-3 full cycles.

0
1162
12
goldi wrote:

I think its a battery issue, most probably it is at end of life cycle.
There are some secret codes for asus to check hardware functionality.
I can’t remember exactly but google it and try on your own risk.
Check this page https://mobileresets.com/asus-secret...es
*#0228# is battery status code there mentioned but before trying anything back up data.

I have checked, Battery test shows Status- Good

0
1162
12
deb3l wrote:

You did all recent firmware updates bro? I think it needs a battery upgrade, nothing else. Is it still booting up?

System is Updated,
mobile boot only after plugging in to power socket

0
1162
12
deal_heist wrote:

where u using a charger other than d one provided by company?

No,
Brand charger only

Missing