Android problem - multiple (upto 4) duplicate c...

Android problem - multiple (upto 4) duplicate contacts

Score: 4 Votes: 4
Score: 4 Votes: 4
Score: 4 Votes: 4
Score: 4 Votes: 4
Heavyball2 med 1
Deal Cadet
0
84
362
35

Somehow my android phone contacts are messed up. Some are in whatsapp account, some in gmail, some in mi account, some in phone. All this has led to multiple copies of same contacts, upto 4 duplicates. Is there a app to sort this out? Also the Gmail contact doesn’t have whatsapp link, etc. How do you guys manage this mess?

  • In
18 Comments  |  
11 Dimers
Thumbimgcrop 1448092580431
Deal Subedar
3
157
1328
15

Try searching on playstore , their is an app which deleted multiple contacts .

Heavyball2 med 1
Deal Cadet
0
84
362
35

The problem is that suppose I have a contact called Rahul Gandhi with 1 home mobile, 1 office mobile, and 1 home phone, 1 email address. There will be 4 duplicates, 1 having only email address, other 3 having the 3 phone nos. That’s frustrating. The Merge contacts & Duplicate delete inbuilt android features are not working.

Images %281%29
Entertainer
8
9
23750
225

@dragonball First of all, under settings go to Accounts, Google, and Sync contacts. When sync is complete. Login to same account via www.google.com/co...ts using Desktop version. Now select merge duplicates, it will show you all one by one, just see once and merge.

Missing
Deal Lieutenant
2
336
4362
52
@Plato wrote:

@dragonball First of all, under settings go to Accounts, Google, and Sync contacts. When sync is complete. Login to same account via www.google.com/co...ts using Desktop version. Now select merge duplicates, it will show you all one by one, just see once and merge.


Try to understand his problem.. he’s got 3 Rahul Gandhi’s at three different places… https://cdn2.desidime.com/assets/textile-editor/icon_wink.gif

ad bot
1
1
1
1
Ad Bot

I found this sponsored content on one of the ad networks.

Missing
Deal Newbie
0
51
90
3

+1 you can merge all contacts using this

@Plato wrote:

@dragonball First of all, under settings go to Accounts, Google, and Sync contacts. When sync is complete. Login to same account via www.google.com/co...ts using Desktop version. Now select merge duplicates, it will show you all one by one, just see once and merge.


Heavyball2 med 1
Deal Cadet
0
84
362
35

^It’s not working. I tried it on some samples
1 – The contacts are merged but there is no whatsapp icon in phone meaning i can not whatsapp these contacts. There is a different whatsapp contact with only whastapp number in it and on email, etc details. Meaning there are still duplicates!

Missing
Deal Cadet
0
72
392
13

In contacts app, set the “Contacts to display” to local contacts or gmail contacts (The primary gmail you sync your contacts to). Duplicates won’t appear.

Permanent solution :

  • After doing the above method, Check if all the contacts are present, take a offline backup of your contacts to sd card or internal storage.
kill Mi sync, kill gmail sync, delete your contacts on gmail & phone (Complete wipe). Restored the locally backed up contacts (vcf file), switch back the gmail contacts sync. Don’t turn on Mi sync. The newly added will be added to your phone and gmail account syncd …
Missing
Deal Newbie
0
51
90
3
@dna_uncut wrote:

In contacts app, set the “Contacts to display” to local contacts or gmail contacts (The primary gmail you sync your contacts to). Duplicates won’t appear.


I guess this option is not present in newer androids.

Heavyball2 med 1
Deal Cadet
0
84
362
35

Is there a way to modify whastapp account contact so that they reflect the changes made to gmail contacts?

Missing
Deal Cadet
0
72
392
13

In WhatsApp settings – contacts – uncheck show all contacts

Stupendous man
Deal Captain
0
287
8424
89
@dna_uncut wrote:

In contacts app, set the “Contacts to display” to local contacts or gmail contacts (The primary gmail you sync your contacts to). Duplicates won’t appear.

Permanent solution :

  • After doing the above method, Check if all the contacts are present, take a offline backup of your contacts to sd card or internal storage.
kill Mi sync, kill gmail sync, delete your contacts on gmail & phone (Complete wipe). Restored the locally backed up contacts (vcf file), switch back the gmail contacts sync. Don’t turn on Mi sync. The newly added will be added to your phone and gmail account syncd …

+1
GOto contacts>settings and choose the type of contacts to display

Thumbimgcrop 1457030356802
Deal Cadet
1
84
550
6

Same problem ..and also name interchanged in contacts .

Heavyball2 med 1
Deal Cadet
0
84
362
35
@dna_uncut wrote:

In contacts app, set the “Contacts to display” to local contacts or gmail contacts (The primary gmail you sync your contacts to). Duplicates won’t appear.

Permanent solution :

  • After doing the above method, Check if all the contacts are present, take a offline backup of your contacts to sd card or internal storage.
kill Mi sync, kill gmail sync, delete your contacts on gmail & phone (Complete wipe). Restored the locally backed up contacts (vcf file), switch back the gmail contacts sync. Don’t turn on Mi sync. The newly added will be added to your phone and gmail account syncd …

This does NOT work either.
I deleted all the contacts in gmail, whatsapp, MI, phone after a VCF backup of contacts. Signed out of MI account too. Now if I load the backup VCF into phone and try to sync, it somehow doubles the number of contacts on the phone and in midway gives a warning saying too many contacts deletions – undo/delete/do nothing. Also, the sync almost doubles the number of contacts on Gmail (strange)
This is totally messed up now. Someone help?

Giphy
Deal Cadet
0
55
152
5

There is an android app called duplicate contacts in playstore. Use it.
The developer name is alex accaci.
It will work.

PS. Plz do make a complete backup of your contacts before you do anything.

Missing
Deal Cadet
0
72
392
13
@dragonball wrote:

@dna_uncut wrote:

In contacts app, set the “Contacts to display” to local contacts or gmail contacts (The primary gmail you sync your contacts to). Duplicates won’t appear.

Permanent solution :

  • After doing the above method, Check if all the contacts are present, take a offline backup of your contacts to sd card or internal storage.
kill Mi sync, kill gmail sync, delete your contacts on gmail & phone (Complete wipe). Restored the locally backed up contacts (vcf file), switch back the gmail contacts sync. Don’t turn on Mi sync. The newly added will be added to your phone and gmail account syncd …

This does NOT work either.
I deleted all the contacts in gmail, whatsapp, MI, phone after a VCF backup of contacts. Signed out of MI account too. Now if I load the backup VCF into phone and try to sync, it somehow doubles the number of contacts on the phone and in midway gives a warning saying too many contacts deletions – undo/delete/do nothing. Also, the sync almost doubles the number of contacts on Gmail (strange)
This is totally messed up now. Someone help?


You could have sync your contacts to more than one gmail account, so once you switch on sync it sync the contacts from other gmail too. Did you delete the gmail contacts from windows or andriod? Just login into your gmail account using windows, wipe your contacts (Wipe it from other gmail accounts too If you have more than one).

Delete your phone contacts (Hope you have a offline backup), sign in to gmail from your phone. It will have 0 contacts to sync. Once sync, restore the offline backup. Now the restored backup will be sync to your gmail account …
  • Check if you are offline backing up the local contacts only, not all (gmail, whatsapp, mi etc). Because if you offline backup everything, it itself have multiple duplicate contacts present …
Choose the ‘contacts to display’ to local contacts in the contacts app and then take a offline backup …
Yoyo
Deal Lieutenant
0
6
5554
211

google.com/contact
login through that google account, their is a option to merge all duplicate options, that works perfectly.

Heavyball2 med 1
Deal Cadet
0
84
362
35
@dna_uncut wrote:

@dragonball wrote:

@dna_uncut wrote:

In contacts app, set the “Contacts to display” to local contacts or gmail contacts (The primary gmail you sync your contacts to). Duplicates won’t appear.

Permanent solution :

  • After doing the above method, Check if all the contacts are present, take a offline backup of your contacts to sd card or internal storage.
kill Mi sync, kill gmail sync, delete your contacts on gmail & phone (Complete wipe). Restored the locally backed up contacts (vcf file), switch back the gmail contacts sync. Don’t turn on Mi sync. The newly added will be added to your phone and gmail account syncd …

This does NOT work either.
I deleted all the contacts in gmail, whatsapp, MI, phone after a VCF backup of contacts. Signed out of MI account too. Now if I load the backup VCF into phone and try to sync, it somehow doubles the number of contacts on the phone and in midway gives a warning saying too many contacts deletions – undo/delete/do nothing. Also, the sync almost doubles the number of contacts on Gmail (strange)
This is totally messed up now. Someone help?


You could have sync your contacts to more than one gmail account, so once you switch on sync it sync the contacts from other gmail too. Did you delete the gmail contacts from windows or andriod? Just login into your gmail account using windows, wipe your contacts (Wipe it from other gmail accounts too If you have more than one).

Delete your phone contacts (Hope you have a offline backup), sign in to gmail from your phone. It will have 0 contacts to sync. Once sync, restore the offline backup. Now the restored backup will be sync to your gmail account …
  • Check if you are offline backing up the local contacts only, not all (gmail, whatsapp, mi etc). Because if you offline backup everything, it itself have multiple duplicate contacts present …
Choose the ‘contacts to display’ to local contacts in the contacts app and then take a offline backup …

This method worked finally. Thank you.

Missing