Hot Deal Jio ADD On data problem

515°
Missing
Deal Subedar
647
1691
22

Guys I recently bought a jiofi device and recharged my sim with 399 plan which gives 1.5GB/day. I received a ADD ON voucher in my account which gives 1.5GB/day extra. I successfully redeemed the ADD On voucher but I am not receiving any benefit from that voucher. Once my regular 1.5GB/day is over, my speed reduced to 50kbps although I should get additional 1.5GB/day.

Any useful information/solution regarding this will be appreciated. /\

12 Comments  |  
6 Dimers
Missing
Deal Cadet
105
251
0

Add on voucher on active state on your account? Share screenshot

Missing
Deal Subedar
647
1691
22
Aveejeet wrote:

Add on voucher on active state on your account? Share screenshot

Yes it’s active https://cdn0.desidime.com/attachments/photos/592456/original/IMG_20191024_224715.jpg?1571937478

Missing
Deal Cadet
105
251
0
Expand
TheAce wrote:

Yes it’s active https://cdn0.desidime.com/attachments/photos/592456/original/IMG_20191024_224715.jpg?1571937478

Yes. It’s on active state. May be som kind of network problem. Let see if problem continues

Missing
Deal Subedar
647
1691
22
Expand
Aveejeet wrote:

Yes. It’s on active state. May be som kind of network problem. Let see if problem continues

Just now had an interaction with jio customer care and still nothing resolved.
They told me that I received the add on voucher for a different device and not the jiofi device and that I will be able to use that add on voucher only when my sim card is inserted in that particular device. So I realised I had activated the sim card in my Redmi Note 7 and immediately inserted the sim card back into the phone. But I was still not able to use the additional 1.5GB data so I called jio customer care back. And now they are saying that the device I used was a Redmi Note 6 and not Note 7. I dont even have a Redmi Note 6 in my house.
What’s even worse is that the customer care girl disconnected my call (when she couldn’t resolve my issue) by saying that she was unable to hear my voice even when I could hear her properly.

Missing
Deal Newbie
51
20
0
Expand
TheAce wrote:

Just now had an interaction with jio customer care and still nothing resolved.
They told me that I received the add on voucher for a different device and not the jiofi device and that I will be able to use that add on voucher only when my sim card is inserted in that particular device. So I realised I had activated the sim card in my Redmi Note 7 and immediately inserted the sim card back into the phone. But I was still not able to use the additional 1.5GB data so I called jio customer care back. And now they are saying that the device I used was a Redmi Note 6 and not Note 7. I dont even have a Redmi Note 6 in my house.
What’s even worse is that the customer care girl disconnected my call (when she couldn’t resolve my issue) by saying that she was unable to hear my voice even when I could hear her properly.

Can do a small top up/ addon recharge like 10/11, it will probably reset/rejig your account.
Ps- I CAN’T guarantee that it will work. But worth a try.

Missing
Deal Subedar
647
1691
22
Expand
aaa.aditya wrote:

Can do a small top up/ addon recharge like 10/11, it will probably reset/rejig your account.
Ps- I CAN’T guarantee that it will work. But worth a try.

Thanks. I’ll try it.

Missing
Deal Newbie
50
20
0

Is this solved your problem buddy? Recharging your phone with new add on or topup

Missing
Deal Subedar
647
1691
22
JackReacher007 wrote:

Is this solved your problem buddy? Recharging your phone with new add on or topup

No bro it didn’t solve the issue.

Missing
Tech Guru
222
19356
188
Expand
TheAce wrote:

No bro it didn’t solve the issue.

get one more addon voucher by queuing one more recharge smile

Missing
Deal Newbie
50
20
0

Same happened to me.. they said voucher can be used with my old device only so I didn’t tried and gave up

Missing
Deal Newbie
50
20
0

i recharged for 1year 2gb/day.. i got ADD ON 2gb/day . But now i changed my phone and then ADD ON is still there but can’t use it.. i just gave up..coz i changed
the device

Missing