Payzapp requires minimum iPhone XR and iOS 17 🤬

283°
Deal Cadet
nando

Appstore requirements says iOS 15, was working perfectly suddenly unable to do UPI (error 401)

I deleted and reinstalled app now unable to login

Wallet balance and cashpoints stuck, don't have another iOS device on 17 or Android device

Many recent reviews on appstore having similar problem

HDFC cheating by locking out customers from their app, yet to get receive reply from cc

IMG0133.PNG

img-0134

img-0135

img-0136

img-0137



Top Comments
Benevolent Benevolent
Link Copied

They should have announced this is advance before pushing this update. Big issue in case of apps that don't have a web presence. NPCI does some ridiculous things. In an old device usage of UPI Lite had been blocked. Paytm, Phonepe clearly mentioned that it was due to regulatory guidelines. Upon complaining to NPCI they first said they will investigate the issue but later brazenly stated that don't block any device. I left it that. 

Pockets with the latest update doesn't run once it detects that the device has been rooted. Even if one then chooses to unroot. At least one can still move out Wallet balance in such a case. Also all of a sudden it asked to enter the DOB. In case of a mismatch it won't allow login. Fortunately I had given the correct DOB at the time of account creation. Also I might have found a way to use it in (KSU )rooted devices once again

Generous Generous
Link Copied

-How many of u think its effort of american corp. to discourage UPI use among middle class Indian who are UPI highest user and usually have not-up-to-date Iphone so as to let master/visa take way

Deal Newbie Deal Newbie
Link Copied

it is a requirement by NPCI which is an Indian company😬. They are forcing users to update to iOS 17 because of security requirements for upi, and apple and google are only following their requirements. One of the requirements is for upi sim binding, which is introduced in ios 17 only.


You can see this was created at the request of NPCI itself, the name of this check is "upi device validation" in apple's developer site. If the device is not on ios 17, this check fails and the upi activation request is rejected.


https://developer.apple.com/documentation/bundl...

40 Comments  |  
18 Dimers
  • Sort By
Deal Captain Deal Captain
Link Copied

Android 🗿🗿🗿🗿

Benevolent Benevolent
Link Copied

They should have announced this is advance before pushing this update. Big issue in case of apps that don't have a web presence. NPCI does some ridiculous things. In an old device usage of UPI Lite had been blocked. Paytm, Phonepe clearly mentioned that it was due to regulatory guidelines. Upon complaining to NPCI they first said they will investigate the issue but later brazenly stated that don't block any device. I left it that. 

Pockets with the latest update doesn't run once it detects that the device has been rooted. Even if one then chooses to unroot. At least one can still move out Wallet balance in such a case. Also all of a sudden it asked to enter the DOB. In case of a mismatch it won't allow login. Fortunately I had given the correct DOB at the time of account creation. Also I might have found a way to use it in (KSU )rooted devices once again

Benevolent Benevolent
Link Copied

UPI liye support up to which Android version?

View 2 more replies
Benevolent Benevolent
Link Copied

Switch back to old version?

Deal Cadet Deal Cadet
Link Copied

Can’t download older version in iOS 

View 2 more replies
Benevolent Benevolent
Link Copied

@nando Old Payzapp versions can be run in Android emulators. They don't demand SIM binding. But maybe they won't work anymore especially after a user has migrated to Payzapp 2.0.

Otherwise if you can borrow a non-Samsung, Android device for a few minutes you can run Payzapp in Work Profile in Island and use Wallet balance. Thereby causing zero disturbance to the owner's device.

Deal Cadet Deal Cadet
Link Copied

At least app is allowing to raise ticket, will see if they transfer my wallet balance to bank account or else I will have to borrow someone’s phone. 
wallet balance is less than 100 but what if someone has huge amount and they are locked out, it is just ridiculous by HDFC

Finance Ninja Finance Ninja
Link Copied
imobile also not working on ios 15.7
Deal Cadet Deal Cadet
Link Copied
HDFC App also not allowing UPI registration unless update to iOS 17
Deal Cadet Deal Cadet
Link Copied

Even ICICI mobile app is not working anymore in iPhone X

Deal Cadet Deal Cadet
Link Copied

Planned obsolescence

All are involved in this, just want us to throw away perfectly working phones and purchase new ones

Deal Cadet Deal Cadet
Link Copied

did away with iphone 6s and iphone 7 and replaced it for pova 5 pro 5g got 8100 and 9700 for them ,dint want to but expected this and next year no more upi also possible on ios 15 

Blaze Blaze
Link Copied

So from 1st Jan 2024, minimum IOS version for UPI is IOS 17 ?

IOS users please confirm if on IOS 15 UPI still working

@LIMBO

Deal Cadet Deal Cadet
Link Copied
amazon and phonepe still working on ios 15
View 6 more replies
Generous Generous
Link Copied

-How many of u think its effort of american corp. to discourage UPI use among middle class Indian who are UPI highest user and usually have not-up-to-date Iphone so as to let master/visa take way

Deal Newbie Deal Newbie
Link Copied

it is a requirement by NPCI which is an Indian company😬. They are forcing users to update to iOS 17 because of security requirements for upi, and apple and google are only following their requirements. One of the requirements is for upi sim binding, which is introduced in ios 17 only.


You can see this was created at the request of NPCI itself, the name of this check is "upi device validation" in apple's developer site. If the device is not on ios 17, this check fails and the upi activation request is rejected.


https://developer.apple.com/documentation/bundl...

View 2 more replies
Deal Cadet Deal Cadet
Link Copied

Even Gpay doesnt work 

Deal Cadet Deal Cadet
Link Copied

which phone do you have?

Deal Cadet Deal Cadet
Link Copied

6s

View 1 more reply
Helpful Helpful
Link Copied

Bhim upi also not working on ios 16

Generous Generous
Link Copied

Nice way to force user to upgrade. Lol

Benevolent Benevolent
Link Copied

Thanks to aftermarket development Payzapp can be made to run even in rooted Android devices as old as 10 years! Personally using in 2 devices launched 8 years ago. This can change anytime though w.r.t. root especially and/or (to a lesser extent) unlocked bootloader. 

Deal Cadet Deal Cadet
Link Copied

Update : Spoke to CC, said if they transfer the wallet balance & cashpoints to bank account then my payzapp account will be blocked. As it was less than Rs 20 I told them to leave it as it is.

Benevolent Benevolent
Link Copied

Payzapp isn't anywhere as rewarding so as to justify unnecessarily spending tens of thousands on a new device. Different matter if most apps follow suit.

View 1 more reply
Deal Newbie Deal Newbie
Link Copied

This is highly unprofessional on the part of Banks and NPCI to force their customers to change their perfectly working phone. I had recently upgraded my mobile to Apple X from my earlier Apple 7, now my Canara Mobile Apo is not working as Apple X does not have IOS 17. The entire issue appears to be fishy and needs to be investigated to safeguard customers interests.

Deal Cadet Deal Cadet
Link Copied
Looks like all apps now require ios17 to register upi
Just tried registering phonepe on ios 15 but says npci requirements to update to ios 17.
But phonepe and amazonpay already activated are working fine on ios 15, don't know how long they will work!!!

So any iphone lower than xr are useless in India (cause upi is must have app on phone)

Apple definitely paid NPCI !!!
replyuser
Click here to reply
Reply