Hot Deal (Resolved) Urgent: Mobile Bluetooth auto disconnect issue.

705°
Mumbai Indians
129
10170
125

Hello Folks,
I am using max pro m1 and i recently bought boult audio airbass powerbuds when i am connected to my earbuds and talking to someone over a call the earbuds auto disconnects after sometime and again gets connected to my phone and this goes on and it’s pretty frustrating. This is happening mainly when the screen goes off. I am using 084 update on my 6gb model right now and i still haven’t rooted my phone. The moment the screen goes off the phone BT auto connects after few seconds and this goes on.

PS – I already tried clearing my cache in recovery mode and also did reset my network settings too.

Looks like there is some display/bluetooth/battery setting which needs to be unchecked so that i can use it properly.

I even tried connecting these buds to another Vivo smartphone but i didn’t face any issues there.

Any boult earbud users here can help me in a better way. I will still test these earbuds in other phones as well since i have the return window open for a couple of days.

Appreciate your comments.

TIA.#ApkaApnaJJ:)#Staysafeandhealthy.
Tagging some dimers here @Imharsh @bikidas2060 @malikcool @desiman @androgame @_One_Miller_ @BubbleBoyChickenLittle @GoogleCA @Ramesh1997 @cocay @guest_999 @manyfacegod @deb3l @Total_Fun @rajeshcaicwacs259 @Original @getready @mastervijay

74 Comments  |  
18 Dimers
  • Sort By
479
29112
327

Doesn’t look like this is settings related (something like Deep Battery Optimization for OP Phones) as the earbuds are getting auto-disconneted & getting connected again

665
4667
53

When did this issue started? Usually some system/os update cause such issue. If it is from the beginning then you can try reverting to factory reset setting but this seems too much hassle just to figure out this issue.

174
3479
29

Go to settings. Search battery optimization. Then again select battery optimization. On the top there is a drop down menu, select all apps. Then search bluetooth and click on it. Select don’t optimize.

2,374
5190
27

Does the Bluetooth buds get auto connected even when your phone display is off?
Or do they auto connect only when the display is turned on?

129
10170
125
getready wrote:

Doesn’t look like this is settings related (something like Deep Battery Optimization for OP Phones) as the earbuds are getting auto-disconneted & getting connected again

confused cry
129
10170
125
guest_999 wrote:

When did this issue started? Usually some system/os update cause such issue. If it is from the beginning then you can try reverting to factory reset setting but this seems too much hassle just to figure out this issue.

I got these buds this week itself and i am having this issue from the very first day. confused

129
10170
125
SleeperRAW wrote:

Go to settings. Search battery optimization. Then again select battery optimization. On the top there is a drop down menu, select all apps. Then search bluetooth and click on it. Select don’t optimize.

Yes bro i have already done this still i am facing this issue cry
PS – BT as well as BT Midi service is not being optimized.

129
10170
125
ManyFaceGod wrote:

Does the Bluetooth buds get auto connected even when your phone display is off?
Or do they auto connect only when the display is turned on?

Yes these buds get auto disconnected because my phone Bluetooth goes off and the moment the phone BT turns on the earbuds auto connect once again. confused

174
3479
29
Expand
MrKool_JJ wrote:

Yes bro i have already done this still i am facing this issue cry
PS – BT as well as BT Midi service is not being optimized.

Background restrictions?

2,374
5190
27
Expand
MrKool_JJ wrote:

Yes these buds get auto disconnected because my phone Bluetooth goes off and the moment the phone BT turns on the earbuds auto connect once again. confused

Then there is definitely some battery optimization going on.
You will need to find it and disable it.
I have no idea about Asus OS, but as they usually have close to stock android os, try to disable any battery optimization setting u can find in “battery option” in “settings”.

174
3479
29
Expand
ManyFaceGod wrote:

Then there is definitely some battery optimization going on.
You will need to find it and disable it.
I have no idea about Asus OS, but as they usually have close to stock android os, try to disable any battery optimization setting u can find in “battery option” in “settings”.

There is no Asus OS smile. The phone comes with pure android installed with it.

665
4667
53

Just some wild guesses:
Launch music player in the background with a song playing connected to BT buds & then make a call from other phone to own number. The playing song should pause & you will receive the call, see if it works without issues now,

Install some call recording app & set it to auto record every call & then see if issue happens.

6
15132
137
Expand
MrKool_JJ wrote:

Yes i went to developer options and searched for A2DP but this option is already checked and it’s freezed out for me as well which means i can’t make any changes here cry
What to do bhai?

Bhai. I checked it. You are right. Just toggle the development button, once. And you ll be able to toggle the frozen button

129
10170
125
Expand
SleeperRAW wrote:

Background restrictions?

As of now my restricted system apps are livedemoservice, bug reporter proxy, location services, calendar storage, configupdater, quickstep, bug reportor, device health & asus config update

129
10170
125
Expand
SleeperRAW wrote:

There is no Asus OS smile. The phone comes with pure android installed with it.

Yes it’s complete stock ui.

129
10170
125
Expand
ManyFaceGod wrote:

Then there is definitely some battery optimization going on.
You will need to find it and disable it.
I have no idea about Asus OS, but as they usually have close to stock android os, try to disable any battery optimization setting u can find in “battery option” in “settings”.

That’s what i am also trying to figure out.
What do i have to disable i didn’t get you.

129
10170
125
Expand
bikidas2060 wrote:

Bhai. I checked it. You are right. Just toggle the development button, once. And you ll be able to toggle the frozen button

The “Disable Bluetooth A2DP Hardware Offload” had been greyed out in the activated position and as you advised me “To make it switch able I turned off Bluetooth then turned developer mode off then back on without leaving developer mode and it make it switch able It worked, but after switching modes, the phone restarted, switched on the option and greyed out again”.

479
29112
327
Expand
MrKool_JJ wrote:
confused cry

The issue seems to be more or less related to the earbuds themselves & their compatibility w/ your device/OS
Get a different pair of earbuds (better if they have same BT version & the codec support) & test them
If they work fine, then the only possible solution is to replace earbuds.. nothing else will work (as I seriously doubt if/when there’s gonna be a firmware update by Boult as these are rebranded ones)

129
10170
125
Expand
getready wrote:

The issue seems to be more or less related to the earbuds themselves & their compatibility w/ your device/OS
Get a different pair of earbuds (better if they have same BT version & the codec support) & test them
If they work fine, then the only possible solution is to replace earbuds.. nothing else will work (as I seriously doubt if/when there’s gonna be a firmware update by Boult as these are rebranded ones)

But this was perfectly working fine on Vivo u10 (i still check this with my another redmi phone as well)
I am really confused and still thinking what to do.
Unfortunately, this is the only pair of BT earbuds i have confused

665
4667
53
Expand
MrKool_JJ wrote:

But this was perfectly working fine on Vivo u10 (i still check this with my another redmi phone as well)
I am really confused and still thinking what to do.
Unfortunately, this is the only pair of BT earbuds i have confused

Android devices have different firmwares/os versions so even if a BT device is working fine with an android phone then it does not mean it will definitely work fine with another android phone running same version of android. That is why Apple ecosystem wins hands down when it comes to compatibility.

155
2837
39

Try Installing Arogya Setu app and give all permissions. It won’t let system turn off the bluetooth ! #DigitalIndia

57
282
3
sherlock wrote:

Try Installing Arogya Setu app and give all permissions. It won’t let system turn off the bluetooth ! #DigitalIndia

Lol

129
10170
125
sherlock wrote:

Try Installing Arogya Setu app and give all permissions. It won’t let system turn off the bluetooth ! #DigitalIndia

weary sweat
307
2106
10
sherlock wrote:

Try Installing Arogya Setu app and give all permissions. It won’t let system turn off the bluetooth ! #DigitalIndia

Haha good one joy

140
468
5

check battery saver option ! https://cdn0.desidime.com/attachments/photos/631457/medium/Screenshot_20200816-175342.png?1597580775

262
3529
20
Expand
MrKool_JJ wrote:

As of now my restricted system apps are livedemoservice, bug reporter proxy, location services, calendar storage, configupdater, quickstep, bug reportor, device health & asus config update

Just a guess
Remove location from restricted options and try
Also remove battery optimization from everything and try once

Missing